Como instalar o GLPI

Olá pessoal…

Hoje eu vou mostrar como instalar o GLPI, utilizando uma base de testes com Windows e XAMPP.

Primeiramente é necessário ter instalado o MySQL / MariaDB e o PHP, no caso do Windows, você pode fazer isso instalando o XAMPP (Saiba Mais).

Faça o download o GLPI através do link glpi-project.org/spip.php?article41, após fazer o download, descompacte na pasta de instalação do xampp, dentro de htdocs.

Inserindo o diretório descompactado do glpi

Inserindo o diretório descompactado do glpi

Escolha o idioma de instalação.

Idioma da instalação

Idioma da instalação

Leia os termos do contrato e clique em aceitar.

Contrato de instalação

Contrato de instalação

Clique na opção Instalar.

Opção de Instalação ou Atualização

Opção de Instalação ou Atualização

Se ele mostrar alertas quanto ao ldap e imap, será necessário alterar algumas configurações.

Alertas de recursos da instalação

Alertas de recursos da instalação

Para alterar as configurações do ldap e imap, acesse dentro da pasta de instalação do xampp, a pasta php, e em seguida o arquivo php.ini, descomente (tirar o ; do começo da linha) então as linhas que tem “extension=php_imap.dll” e “extension=php_ldap.dll”.

Editando o php.ini

Editando o php.ini

Verifique novamente se há algum aviso de alerta.

Revisando requisitos

Revisando requisitos

Informe a base de dados, o usuário e a senha, como nossa base é local, coloquei localhost, e o usuário e senha do meu MariaDB estava como root e senha em branco.

Informando dados da conexão com o banco de dados

Informando dados da conexão com o banco de dados

Caso queira testar a senha, acesse localhost/phpmyadmin para fazer o login no MariaDB / MySQL.

Escolha a opção de criar uma base de dados, ou utilize uma que você já tenha criado.

Informando informações da base

Informando informações da base

Prossiga com a instalação.

Prosseguindo com a instalação

Prosseguindo com a instalação

A instalação mostrará uma mensagem de que foi concluída com sucesso.

Tela final da instalação

Tela final da instalação

Agora basta utilizar o GLPI, lembrando que recomendam alterar as senhas dos usuários, por padrão vem o usuário glpi com a senha em branco. E também recomendam excluir o arquivo install.php.

Tela inicial do GLPI

Tela inicial do GLPI

Referências:
jbwebmaster.wordpress.com
marcio5903.wordpress.com

Bom pessoal, por hoje é só.
Abraços e até a próxima.

Dan Atilio (Daniel Atilio)
Especialista em Engenharia de Software pela FIB. Entusiasta de soluções Open Source. E blogueiro nas horas vagas.

15 Responses

  1. jackson disse:

    aqui fica só em ‘Iniciando banco de dados’, e não passa.

  2. Thiago disse:

    Cara no servidor está da mesma forma n passa da etapa 3 , poderia ajudar?

  3. Thiago disse:

    Estou com o mesmo problema na etapa 3 na versão 9.3 porem na 9.2 passa normal.
    Gostaria de saber porque ocorre na verão 9.3, estou utilizando o XAMPP

  4. Estou com o mesmo problema na etapa 3 na versão 9.3 porem na 9.2 passa normal.
    Gostaria de saber porque ocorre na verão 9.3, estou utilizando o XAMPP

  5. Ana Eliza disse:

    Muito bom o tutorial , simples e didático.

  6. A extensão APCu não está presente
    A extensão xmlrpc não está presente
    A extensão CAS não está presente

    Ja fiz de tudo e nem ja pesquisei de tudo e nada aqui ja resolveu

    • Dan_Atilio disse:

      Boa tarde Weverton, tudo bem?
      A instalação é local ou servidor? Qual sistema operacional? Se for Windows, qual versão do XAMPP? Se for Linux, qual versão do Apache, PHP e MySQL / MariaDB?
      Se for em servidor, já tentou contactar o provedor da hospedagem?
      Grande abraço.

  7. Leonardo disse:

    Estou com o mesmo problema:

    A extensão APCu não está presente
    A extensão xmlrpc não está presente
    A extensão CAS não está presente

    SO: Windows 7
    XAMPP Control Panel v3.2.3

  8. Leone Athayde Salarini disse:

    Consegui resolver o problema de algumas extensões, com exceção da “CAS”

    A extensão CAS não está presente

    SO: Windows 10
    XAMPP Control Panel v3.2.2

Deixe uma resposta